Resolved
The incident involving Emplifi UGC Digital Display has been resolved.
All performance metrics are back to normal.
We apologize for any inconvenience this may have caused.
Investigating
We are currently investigating an Outage affecting Emplifi UGC Digital Display
Our engineering team is actively looking into the root cause and working to restore optimal performance.