Complete
Maintenance finished.
In progress
Maintenance started.
Scheduled
Emplifi Bot - Changes to Bot Settings, default behaviours & removal of unsupported legacy channels
We will be releasing a new version of Emplifi Bot. This version includes:
Changes to Bot Settings - Continuing the plan to improve usability and efficiency of the Bot platform, we are releasing a new "in-authoring" Settings menu (located in the taskbar at the top of the screen). This will provide access to a settings interface for each Bot from within the Authoring interface, allowing users to better utilise the recent UX improvements and make settings changes without leaving the Authoring interface. This change also removes some unused legacy settings and updates tooltips/instructional copy for various optional settings.A subsequent release will update the main Bot "Overview" page for a better user experience.
Default behaviour changes - Various minor changes have been made with certain settings, enabling them by default instead of requiring user intervention to enable them. This includes a default timeframe for inserting conversation breaks and automatically enabling that setting in order to populate Containment analytics for any newly created Bot.
Removal of Twilio Whatsapp - After developing a direct integration via Emplifi Suite and Whatsapp for Business last year, we have removed Twilio Whatsapp as a channel. Whatsapp for Business can still be utilised as a Bot channel and is supported via an embedded sign-up flow directly within Emplifi, providing a better experience for users.
Updated conversation annotations for escalation queues - When escalating to a human agent, the conversation annotations have been updated with additional events to clarify when an escalation has been accepted, declined, or timed out by the agent, providing more detail for escalation & containment analytics.
Whatsapp for Business carousel conversion logic - Due to Meta restrictions and guidelines regarding the use of media assets, carousels as they are used in Facebook Messenger, Instagram DMs or Webchat or not available in the same way for Whatsapp for Business. To assist users with this, we have developed a mechanism to detect when a carousel asset is used within a bot that is connected to a Whatsapp channel and will automatically convert that carousel to an interactive message format that is supported on Whatsapp for Business (visually indistinguishable from a typical carousel).
Please note: URL links are not supported as payloads for any buttons on the Whatsapp for Business interactive message format.
There will be no planned downtime as part of this maintenance.